2000 Pontiac Grand Am GT 3.4 V6 Dying while driving 60mph car just shuts off I've replaced the Alternator, Serpentine belt ,Battery and Now MAF Sensor

Jillian87

New member
7
0
1
A couple months ago my car randomly started dying while i was driving a 30 mile distance when driving a steady speed for about 20 mins the car just shuts off all indicator lights come on steering wheel locks up and i have seconds to get off the road in a safe place originally thought it was the Alternator... Clearly wasn't so I replaced that with the Belt still happened then I thought it had to be the battery so i replaced that as well, Still didn't work then I took it to O'rileys and ran the code i got a cam shaft sensor code so i bought that and the crank shaft too but i took it to my local shop they said that would not cause those issues well i seen in the history the Mass Air Flow Intermittent code so i thought i might as well clean it just in case well it worked no issues for 3 weeks them it started back up again so i ran the codes this time i actually had the MAF malfunction code that came for the first time it made since so i bought it thinking i finally fix this POS it even took my service engine light away when i changed it but a week later it came back on but the car had not died yet...So i ran straight to O'rileys and ran the codes again this time it sai MAF or Volume sensor performance... but had not died But today i was driving my daily 30 miles there and back routine and this time it took me 2 1/2 hours to get home bc The car died 7 time I would have to wait like 10 mins the start it back up then it would only drive 1 mile if that before it happened again it also started does this weird shifting in gear kinda hard 2 times before it dies PLEASE HELP MY 12 MONTH OLD IS USUALLY IN THE CAR WHEN THIS HAS HAPPENED ITS NO LONGER SAFE FOR MY KIDS OR MY SELF FOR THAT MATTER
 

92 Sunbird LE

Active member
From what I read online you and many others have had the same problem on these 98 and up Grand Ams.

Check and replace the ignition switch is what most have done.

I think there was a recall on them for the switch also.

Doug in P.R. :cool:
 

melsg5

Staff member
SUSTAINING MEMBER
18,758
27
48
Did you actually let your local shop try to figure out what the problem is?
Can you post the current codes, P0XXX?
 

Jillian87

New member
7
0
1
Did you actually let your local shop try to figure out what the problem is?
Can you post the current codes, P0XXX?
yea they coulnt figure it out hense why im still having the problem Ive spent 800 in part for none of them to fix the issue also no codes as of now
 

melsg5

Staff member
SUSTAINING MEMBER
18,758
27
48
find a different shop with ASE certified technicians and stop guessing as to what the cause is.
what are the current codes including anything that is in history?
______________________________
 

Jillian87

New member
7
0
1
so the car officially wont start at all wont do anything you can tell its trying sound like its starving for gas it last about 2 seconds then shakes crazy then dies never has this happened before
 

Jillian87

New member
7
0
1
find a different shop with ASE certified technicians and stop guessing as to what the cause is.
what are the current codes including anything that is in history?
first was cam shaft then it never came back after codes was reset then history MAF and changed that its at a shop now had to get it towed in bc it died on the side of road and non of these were guesses this is what macanics old me was wrong eith it but was going to be weeks before they could get me in one day i sat there for hours and nothing ran every test nothing came up and he was gm certified
 

Jillian87

New member
7
0
1
It can also be crank sensor or cam sensor
that was my original code but hasn't came back

I think it is your icm it did what mine did put new one one and fine after that u might mention to the ase mac to check
so i had it checked by a ASE mechanic and he said it was the ICM and charged me $840 for a new one and now my battery light is on also said the brand new alt. is bad but was fine when i brought it in and when i was driving to go get the new oneunder waranty thre car starts acting crazy all the gauges start jumping up and down ABS came on and stayed and the no trac. ligh poped on and car got really loud as it drove by itself home i am not kiding the acelerator was not being pushed whatsoever and i was only able to drive by using the brake to slow down PLEASE HELP
______________________________
 

Jillian87

New member
7
0
1
so i had it checked by a ASE mechanic and he said it was the ICM and charged me $840 for a new one and now my battery light is on also said the brand new alt. is bad but was fine when i brought it in and when i was driving to go get the new one under warranty the car starts acting crazy all the gauges start jumping up and down ABS came on and stayed and the no trac. light popped on and car got really loud as it drove by itself home i am not kidding the accelerator was not being pushed whatsoever and i was only able to drive by using the brake to slow down PLEASE HELP
 

Roadkill

New member
9
1
3
Call them back up and tell them sounds like a white didn't get hooked back up these new cars are weird that way are u able to pull any codes? Is engine light on
 
Last edited:

melsg5

Staff member
SUSTAINING MEMBER
18,758
27
48
if the alternator isnt charging the battery the battery will slowly go dead and then all the computer systems will go crazy until they have a fully charged battery and functioning alternator.
______________________________
 
Your email address will not be publicly visible. We will only use it to contact you to confirm your post.
Top