2005 Grand Prix Shifts Hard at Times and Popped a P0420 Code

arthurnichole

New member
Joined
Dec 16, 2013
Messages
1
Reaction score
0
Points
0
I have a 2005 Grand Prix with about 137,000 Miles on it. About a year and a half ago it started shifting hard check engine light did not come on. I got to my destination and didn't drive it again until the next day and it drove like a dream. A couple of months later it happened again and this time the check engine light came on and it had P0420 code. I had a mechanic clear the codes and I went on my way. It was another few months before it started shifting hard again and it immediately popped the same code. Just last week I had the mechanic take a look at the codes again and it was the same code. He cleared it and just Friday (12-13) I took off from a stop light and it shifted hard and popped the code again. He checked all the O2 sensors and the wires and said all were fine.

Anyone have any idea why it is popping a emissions code and not a tranny code?
 

melsg5

Staff member
SUSTAINING MEMBER
Joined
Dec 8, 2008
Messages
23,168
Reaction score
367
Points
83
There are other causes than just the O2 sensors, see the link below. The computer may be trying to compensate for what it feels is insufficient power by causing the transmission solenoids to shift differently. Is your mechanic ASE certified? I also provided another example of someone with the same code and the transmission shifting has changed

http://www.obd-codes.com/p0420

http://autorepair.about.com/library/a/1e/bl187e.htm
 

jw gtp

New member
Joined
Jan 1, 2014
Messages
36
Reaction score
0
Points
0
I have a 2005 Grand Prix with about 137,000 Miles on it. About a year and a half ago it started shifting hard check engine light did not come on. I got to my destination and didn't drive it again until the next day and it drove like a dream. A couple of months later it happened again and this time the check engine light came on and it had P0420 code. I had a mechanic clear the codes and I went on my way. It was another few months before it started shifting hard again and it immediately popped the same code. Just last week I had the mechanic take a look at the codes again and it was the same code. He cleared it and just Friday (12-13) I took off from a stop light and it shifted hard and popped the code again. He checked all the O2 sensors and the wires and said all were fine.

Anyone have any idea why it is popping a emissions code and not a tranny code?




I had a similar problem with my 04 gtp. At about 115,000 my car started shifting hard, jumping into gears and getting confused as to up shift or down shift. The first thing I did was took it in and had the fluid drained and a new filter put in. This eliminated a lot of the problem but not all. I started to notice my heat gauge going hot then cooling down real quick so I changed my heat sensor and thermostat. That fixed the heating problem and believe it or not the transmission stopped acting confused.

At about 120,000 I replaced the cat and both o2 sensors.
 

Xitmnt

New member
Joined
Dec 29, 2019
Messages
13
Reaction score
0
Points
1
What do you mean by heat sensor? Like the coolant temp sensor?
______________________________
 

Xitmnt

New member
Joined
Dec 29, 2019
Messages
13
Reaction score
0
Points
1
Yes, sorry but I was having similar issues and trying to make some sense of what the issue could be.
 
Top