2008 Grand Prix GXP acting very strange

Terry

New member
2
0
1
I have a major problem and am just lost on where to go with it. I installed a new radiator and fan. I hung the fusebox to my hood to make more room. I also had to move the airbox surround to get the radiator out. Never disconnected either. It now is throwing a tcm code and several heater codes. The security system is disabled. It has to be on a charger to keep the battery charged. Alternator and battery are fairly new. Something is killing the charge. Every light known to man is on. It was running but very sluggish. The speedometer would jump when hitting any kind of bump. The last time it moved had to be driven like your great grandpa was driving it. Transmission has been slipping for quite a while but nothing like what it is doing now. Any kind of help would be greatly appreciated. I love my car and hate that I can't drive it. Thanks a lot.
 

melsg5

Staff member
SUSTAINING MEMBER
21,091
172
63
When you started all this work on the car, did you disconnect the battery?
I would very closely look at the fuse box and the wire harness connected to it.
Did you check the alternator output with a voltmeter?
Did you hook up an ammeter to check the draw on the battery and then if abnormally high start pulling fuses till you find the circuit causing the draw?
Can you post the codes?
 

Terry

New member
2
0
1
Battery disconnected, we spent about 5 hours checking power to the wires from the fuse box to the ignition everything had power, haven't checked alternator, all fuses are still good, and I was a little stupid and cleared the codes with my diablo tuner. It currently won't do anything since the security system is disabled. There almost has to be a wire somewhere that is not happy. Would the tcm cause any of these issues? Thanks for the input.
 
Top