brake lights not working

myst3rydfl

New member
2
0
1
i tried searching ( new to site )

had a key issue yesterday , fixed that ,
replacing wheel hub assembly tonight on front passenger side ,

next up is the brake light crap ..

bottom lights not working when brake pedal applied , fiddled around with the turn signal switch lever whilst depressing brake pedal to see if it was a faulty switch in turn signal lever and no difference ,lights didnt flicker or anything so dont see that being issue

there is a million post regarding this issue on other years but non actually for a 2006 , seen 2008 and it is different , has a stop lamp relay ... 2006 doesn't , not that i can see ..

is there a common issue to help me decide what it may be?
like brake control switch ? maybe has a fault rate higher then fuse rates ....
or broken wire in harness at crossover somewhere ?

fuses good ,
top brake light lights up , its on a separate circuit i realize ..


2006 pontiac torrent awd


thanks in advance , any help is greatly appreciated ..
 

melsg5

Staff member
SUSTAINING MEMBER
21,216
184
63
May be a pretty basic thing to check but you made no mention of it.
Are the bulbs burnt out?
Did you check the socket with a test light or voltmeter?
 

myst3rydfl

New member
2
0
1
May be a pretty basic thing to check but you made no mention of it.
Are the bulbs burnt out?
Did you check the socket with a test light or voltmeter?
so replaced hub assembly .. still abs and t/c lights still on and code reader is saying speed sensor has issues on that same wheel ...
but low and behold , was at a buddys and we checked bulbs and both were burnt ....lol couldnt believe it ,, easy fix though haha

have a broken ground on trailer wire hook up so it may have caused that ..
felt like such a retard after checking bulbs
 

melsg5

Staff member
SUSTAINING MEMBER
21,216
184
63
It's always the small things that bite you, glad it was only that.
______________________________
 
Top