Drl (daytime running lights)

Das

New member
Joined
Jan 13, 2022
Messages
1
Reaction score
0
Points
1
Hello, I was wondering if anyone has had issues with the DRL (daytime running lights) on their 2009 Montana SV-6. I checked owners manual for a fuse for that feature but none is shown. Low beams and high beams are working.
I recently did a reset to the instrument cluster which required me to remove both left and right Hi beam fuses and do a ignition on, light switch on off while holding the information reset button. But I'm not sure if I'm did that right and if it affected the DRL. This test was to recalibrate the guages that had been reading radically after a speedo face plate swap was done to convert the Canadian version to US version. This is a Canadian Vehicle. The previous speedo tech may have not reset it properly and so the guages were all over the place. Fuel gauge and coolant temp worked for 2 hours then the needles pegged all the way south. The speedometer was not going past 10 mph then after two hours it went crazy saying I was going 110 mph when GPS read 70mph, and then it got stuck at 80mph even when at a stop light. I recently got the guages to work properly but now the DRL is not working. I did disconnect the battery for 15 minutes and then they seemed to work but now they're not working again. They use to come on as soon as I'd unlock the doors. But now nothing. Later tonight I will see if the auto lights come on for night driving. But if there is a DRL module somewhere that is failing it may affect that!?... I'm not sure what's going. I may attempt to disconnect the battery again to see if that corrects the problem. Thanks in advance for anyone who may be able to assist me in this matter.
 

melsg5

Staff member
SUSTAINING MEMBER
Joined
Dec 8, 2008
Messages
23,286
Reaction score
379
Points
83
DRL is activated by the light sensor on the dash. Anything blocking it, have cleaned it?
 
Top