G5 2.2L Auto lost top gear

PontiacG5Auto

New member
Joined
Oct 25, 2021
Messages
2
Reaction score
0
Points
1
Hi all,

I have a 2007 G5 with about 160k miles on it. Yesterday on the interstate, it seemed to go into neutral.

When accelerating, it goes through the first gears fine, but when it reaches top gear it seems to go into neutral and the engine just revs.

I did add some transmission fluid, but it still didn't help. Going to actually measure the fluid level today.

Being the car is old with high mileage, trying to decide if the thing is basically scrap, or if there are some things I could check.

Thanks for any info!
 

melsg5

Staff member
SUSTAINING MEMBER
Joined
Dec 8, 2008
Messages
23,172
Reaction score
368
Points
83
Have you ever done a fluid and filter change?
Adding fluid without checking level can do more harm than good.
 

PontiacG5Auto

New member
Joined
Oct 25, 2021
Messages
2
Reaction score
0
Points
1
That's a good point. I've had a slight leak through the seal for a while. I was on the road and trying to get the car home, so I tried adding a bit of fluid to see if that would help. Checking the fluid level is a bit of a process, but can do it now since I have the car back home.
 

melsg5

Staff member
SUSTAINING MEMBER
Joined
Dec 8, 2008
Messages
23,172
Reaction score
368
Points
83
That's a good point. I've had a slight leak through the seal for a while. I was on the road and trying to get the car home, so I tried adding a bit of fluid to see if that would help. Checking the fluid level is a bit of a process, but can do it now since I have the car back home.
Ok, good luck
 
Top