Power Steering Issue

rickpo

New member
10
0
0
N.W Arkansas
Hi all. Been a while since ive visited here. I'll get to it.
2000 Grand Am 4cyl engine. Replaced power steering pump 2x. Original one started leaking.
First replacement, the reservoir leaked, got another.
Current one has no leaks.
Problem is that daughter tells me that as the car warms up, the steering will suddenly get real tight. I have bled it more than once. Fluid will go up and down as I turn the wheels. Not sure if there is some sort of bleed screw or something.

Wanted to add, the p.s on this car is not belt driven, it's driven by the cams.

Any ideas? Thanks in advance
 
Last edited:

melsg5

Staff member
SUSTAINING MEMBER
18,595
14
38
So it sounds like you have a 2.4 engine. Can you do a pressure test? Since the problem happens only when warm could be the pump or the steering rack.
 

melsg5

Staff member
SUSTAINING MEMBER
18,595
14
38
you should be able to rent the gauge. I cannt find a number, try a Hanes or Chilton manual, some libraries carry them. There is no hold number, you test with a running engine.
______________________________
 

rickpo

New member
10
0
0
N.W Arkansas
Well just got the pump off. Its lts not a hard job just havent had time. The pin that goes into the cam drive has sheared off. Why does this happen?

PLEASE HELP!!!

Im on my way to get another.
 

rickpo

New member
10
0
0
N.W Arkansas
Good point. I guess it seized up. Got a new one put in. It was under warranty so didn't cost me a thing. Problem is that this is the 3rd one I get from Oreillys. I read NOT to go with a re-manufactured one, but like always... cost is an issue.
So far so good. We'll see how this one works.
 
Your email address will not be publicly visible. We will only use it to contact you to confirm your post.
Top