• Hint: Use a descriptive title for your new message
    If you're looking for help and want to draw people in who can assist you, use a descriptive subject title when posting your message. In other words, "1995 Trans Am" isn't going to indicate to anybody that you need help. However, "Need help with my 1995 Trans Am" will. Be as descriptive as you can. Please use common sense... This message can be closed by clicking the X in the top right corner.

radio works/no display

mikeD

New member
4
0
1
-30 outside and went to boost my 2006 2006 Pontiac torrent,after the car was running the display for clock and radio was blank,the radio works fine,the display is lit up,there just isn't any display info(time or radio station)anybody no what could be the problem,I'm in Edmonton,Canada and it's -30 Celsius today and all week,might have to boost again and I don't want anything else conking out on me.
 

melsg5

Staff member
SUSTAINING MEMBER
20,076
114
63
The boost may have damaged the display screen. You also appear to have a battery that is having an issue or the charging system isnt keeping it fully charged.
 

mikeD

New member
4
0
1
Is there anything I can do besides replace the battery that would stop from anything else going haywire during future boosts?
thanks for your reply
 

mikeD

New member
4
0
1
The boost may have damaged the display screen. You also appear to have a battery that is having an issue or the charging system isnt keeping it fully charged.
Is there anything I can do besides replace the battery that would stop things like this from happening during future boosts?
______________________________
 

melsg5

Staff member
SUSTAINING MEMBER
20,076
114
63
A boost should normally not do this. Did you follow instructions in owners manual on how to boost your car? You need to have the battery tested, not just replace it.
 

mikeD

New member
4
0
1
A boost should normally not do this. Did you follow instructions in owners manual on how to boost your car? You need to have the battery tested, not just replace it.
Fixed! I just went out to the car again,started it and the display fixed on it's own,must have reset itself or something,weird,Cause that's what I thought,that I damaged the display from boosting it. Your right though,I do need to get a new battery in there,don't have an outlet to plug it in,so I have to boost it sometimes when it gets to this temperature,gonna be -35 all next week.I'll have to be more careful when I boost it till I put a new battery in,l was lucky to have it fix on it's own.Thanks for help,at least if anybody else has this problem,they'll know just to leave it for awhile and it might reset!
 
Top