Transmission Issue?!?

Restless

New member
3
0
0
Saskatoon
I got a 07 Pontiac Montana 3.9L V6 OHV 12-valve. Was driving and just lost all gears. I wait a bit once kinda cooled down and it'll engage again but only for a little while.

So far ive cleaned the throttle body, checked fuses and wires, everything is very clean but still same in the end not going into gear or even selecting one.

I got the codes P1516 Throttle Actuator Control, P2101 ECM Tac went out of range, P1692 Driver 5 line 2.

Any tips on what to check or even how to go about this myself? Im very new to repairing things myself so figured id ask around before throwing money around. I thank any response in advance.
 

Restless

New member
3
0
0
Saskatoon
Transmission issue?!?

Sorry for such a late reply melsg5 its been a mess over here.

When it runs cold it'll drive and increase in speed until it warms up, once its hot it'll just rev in place in gear and go no wheres. Sometimes it'll just run and it'll switch a gear sometimes but i cant really take it too far because around here as soon as i get it on the road its got to stop and im dead. Replacing just the throttle control could fix all that?
 

melsg5

Staff member
SUSTAINING MEMBER
18,682
21
38
the throttle control is for no reaction to stepping on the gas pedal, you are stating the engine revs but the vehicle doesnt move. Your issue is trani related, could be a solenoid or the transmission needs to be torn down or replaced.
______________________________
 

Restless

New member
3
0
0
Saskatoon
Transmission issue?!?

Yeah van fires, engages when cold or first started and moves, warms up and nothing unless i turn off and refire but even then moves only so far until i have to stop. Man that sucks if transmission related, guess best to start saving more, really like the van. Thanks !
 
Your email address will not be publicly visible. We will only use it to contact you to confirm your post.
Top